Back to series

If you are running RightFax 9.x, or RightFax 10.0, or RightFax 10.6 we STRONGLY encourage you to upgrade to RightFax 16.2.
Versions prior to RightFax 10.6 will not support Server 2012, Windows 10, Windows 8, or Server 2016.

 

Please enter your information below and we will contact you with the download links and answer any questions you may have.  

If you would like technical assistance planning and installing the upgrades, please let us know.
952-224-3340 Option 1